Lync 2010 Mobile client unable to sign in

October 30, 2016
Phone-VoIP

I was recently contacted by a customer whom I'd deployed Lync 2010 for some time ago and they had decided to patch the servers to the latest Cumulative Update, which as of now is Lync Server 2010 CU10.

Symptoms

I get the call after the changes were completed and problems had begun. The only symptoms that were present were Lync Mobile wasn't working anymore. I go ahead and download and fresh copy of the Lync 2010 mobile client and begin signing into their environment, and sure enough:

This was the error I saw with Auto-Detect turned on
“Unable to sign in.Can't connect to the server.It might be unavailable. Also please check your network connection, sign-in address and server address.”

This was the error I saw with Auto-Detect turned off
“Unable to sign in. Can't connect to the server. It may be busy or temporarily unavailable. Please try again.”

Resolution

First I collected a log from the mobile client and after reviewing it everything looked clear, so I began troubleshooting the Lync Mobile Infrastructure using this great guide by Edwin Joseph : Troubleshooting External Lync Mobility Connectivity Issues Step-by-Step

I ran into a few issues when troubleshooting but nothing definitive because the below sites worked without issue. Autodiscover was giving out all the correct information as I got prompted to open/save the root file.

https://lyncdiscoverinternal.domain.com/autodiscover/ autodiscoverservice.svc/root 
https://lyncdiscover.domain.com/autodiscover/autodiscover.svc/root

From here I started to think they didn't complete the patching procedure correctly so I walked through it with them step by step and we discovered they forgot to run the Install-CSDatabase command after updating all the Lync servers with CU10.

Install-CsDatabase -Update -ConfiguredDatabases -SqlServerFqdn <EEBE.Fqdn> -UseDefaultSqlPaths

Once we ran the above command, Lync mobile worked flawlessly.

Another thing to consider was some users will still run into issues from time to time as they forget to add "domain\username" or username@domain.com" under the mobile settings before trying to sign in. This can also present very similar error messages.

I hope this helps some of you, please leave your comments and follow me on twitter!

Tony Sollars
An Experienced Business Technology Executive with many years of experience in technology and applied leadership skills to develop, grow and mentor businesses and the people that build it.